Jamtaba 2 released!


Hello everybody! After some months with a lot of programming JamTaba 2 is finally released!

Some Jamtaba 2 details:

  1. Jamtaba 2 was totally rewrited in C++ (the old version was writed in Java) and run as a native application (32 or 64 bits). The result is a fast application using less memory and CPU.
  2. Low memory usage. The old version used 300 MB of memory and the new version uses less than 30MB, a huge difference.
  3. Low CPU usage in comparison with the old version.
  4. VST plugins. Jamtaba 2 can act as a VST Host and open VST plugins (32 and 64 bits).
  5. Now you can create 2 stereo channels, and more 2 subchannels.
  6. Chat message translation. In another ninbot forum post the ninjamer Gaz suggested a "translation feature" for chat. It's done, a cool idea!
  7. Better user interface, more clean and beautifull.

Have fun using Jamtaba 2 and please report any problem!

www.jamtaba.com

Elieser

Jon, I'm using Kontakt 5

Jon, I'm using Kontakt 5 here in windows 8.1. What version of Konkat are you using?

Hi Elieser I'm unable tu run

Hi Elieser I'm unable tu run KONTAKT properly. In general other plugins receive midi from an external interface ok, but not KONTAKT. I checked using omni mode too and enable all channels, but the only data it recognizes is CC; no notes are going in.

Hi Gevi, thanks for your

Hi Gevi, thanks for your feedback! I need a better color scheme for xmit button. Stringer suggest a good idea (green and red for xmiting and not xmiting).

If possible tell me the name of problematic plugin and I will put in my list of "plugins to check".

See you!

Hi man, awesome work!! I

Hi man, awesome work!! I just downloaded this 2.0 release and tried the 64 bit version.
Really great!
Very nice to be able to load vstis, vsts from inside jamtaba not having to rely on external apps.
What I really really loved was seeing that ezdrummer syncs to jamtaba's / ninjam servers metro automaticallly !! Loved this!
No more finding the exact sync point, so great!.
So far I only got a certain creash but apparently due to a faulty vsti.
Congrats! Parabens!
Alex

Question: is the "Transmit" button missing a checkbox? I don't know exactly when it's transmitting and when it's not
Brigado

Hi flip, Jamtaba get midi

Hi flip, Jamtaba get midi messages from your connected midi controllers and send to your VST plugins. I think you can use this controller without problems. I don't test amplitube yet, but I test the free LePou plugins and works fine!

Elieser

Hello everybody can i play

Hello everybody
can i play fcb1010 midi controler+ amplitube vst with jamtaba2?

Stringer, try remove the

Stringer, try remove the file Jamtaba64.json in C:/Users/[your user name]/AppData/Local/Jamtaba 2.

This is the Jamtaba 'config' file. Maybe Jamtaba is using a 'old and wrong' information about your devices. Just delete this file, Jamtaba will recreate the file when you reopen.

Please copy your file before delete, so we can see the problematic entries.

Hi Elieser, Jamkazam is

Hi Elieser,

Jamkazam is fully uninstalled and CoCo's error is still blocking Jamtaba after a full reinstall on my machine. I'm guessing activating Jamkazam (which frankly seems too invasive on the ASIO settings) after yesterday's successful test reset something in Jamtaba that residually carried over between installs and/or changed some 8.1 OS settings needed by Jamtaba. May try a slight rollback in recovery to see what happens, but haven't yet... will let you know.

Thanks again for all the cool free stuff... Spin around 3 more times lol!!!

Jon, I'm planning a linux

Jon, I'm planning a linux version too, the Jamtaba code is portable, it's not difficult to build a linux version.

stringer, Jamtaba is trying to use your audio device. If this audio device is opened by other audio application we have problems (I need work in a better solution for this). Check if JamKazam is running in background and check if JamKazam is starting in windows initialization. Skype is a problem too :)
Srtinger, I check the installer script looking for some 'HOMEGROUP" entry, but nothing. Whithout clues at moment :(

Clues Re: Jamtaba2

Clues Re: Jamtaba2 Crashes

Hi Elieser,

I told you my story yesterday... there was no sign of Jamtaba (64) causing crashes and it was working fine except for the 'rooms to play' list regardless of multiple program restarts and computer reboots.

However, today the program refuses to open even after rebooting and I'm getting details that are identical to CoCo's.

There's only one difference I can think of... I played using Jamkazam's app last night and this is the first time I've used Jamtaba since then. I've previously noticed that Jamkazam is very aggressive about taking over the ASIO so other programs can't use it and it likes to run functions in the background unless completely shut down. It wouldn't surprise me if Jamkazam modified something needed by Jamkazam without asking.

Unfortunately, removing Jamkazam didn't fix the problem and running Jamtaba as Admin along with a subsequent reinstall didn't help either. The program now refuses to open giving the details seen in CoCo's post.

I noticed one other interesting thing... there was a new and unexplained MS 'Homegroup' icon on my desktop today (I'm set up as one machine - local only) that disappeared as magically as it appeared when I uninstalled Jamtaba. Hmmmm, strange but true.

Hope this helps...

I love the simplicity of the

I love the simplicity of the new Jamtaba. It's great!. Any plans for a linux version, Elieser?

Coco, I'm running windows

Coco, I'm running windows 8.1 too. Are you running the correct version of Jamtaba (32 or 64 bits)? If you not shure try Jamtaba 32 bits.
Another possibilities: Try run Jamtaba 2 as administrator and try run the installer as administrator too.

Hello, I doesn't have an

Hello,

I doesn't have an antivirus(don't hack me bro :p), i got only windows defender. I added the programs in, but it still doesn't launch.

Thanks.

All species have the same value.

echnaton, I will check

echnaton, I will check Guitar Rig 5 to fix this noise problem.
I'm using Asio4All here and see other ninjamers using too whithout problems. I notice Asio4All save different settings for different applications. When start Jamtaba 2 open the Asio4All config panel (the green icon) and check the configuration. Maybe Asio4All is using wrong devices or something like that.

The chords feature is not available yet in Jamtaba 2, but is in my list.
--------------------------
Coco, try bypass your antivirus, other ninjamers are running Jamtaba without problems bypassing antivirus software (avast is a problem). You can add a rule in your antivirus software to allow Jamtaba as a non-malware :)

Hello, Thanks for this

Hello,

Thanks for this program but it doesn't work for me. I am on windows 8.1. It does not launch, the error is "Jambata 2 as stopped working".

Problem Event Name: APPCRASH
Application Name: Jamtaba2.exe
Application Version: 2.0.0.0
Application Timestamp: 56084dff
Fault Module Name: Jamtaba2.exe
Fault Module Version: 2.0.0.0
Fault Module Timestamp: 56084dff
Exception Code: c0000005
Exception Offset: 000000000000743e
OS Version: 6.3.9600.2.0.0.256.48
Locale ID: 1036
Additional Information 1: 1b3b
Additional Information 2: 1b3ba1bfdd8c69820e9c9300184f01c8
Additional Information 3: 428f
Additional Information 4: 428f6e6461d6ece8e3521df21bbdf7e9

Thanks.

Oh another thing... In

Oh another thing... In version 1 it was possible to display chords! I havent found this cool feature in V2...

Do you have plans on impementing that too? Or is it there and I just havent seen it? :-)

Hey thanks for the hint

Hey thanks for the hint about the antivirus software! I disabled Avast temporary and now Jamtaba runs! :-)

Only thing... when I use "Guitar Rig 5" as a VST on my input channel I get a lot of digital noise! :-0 Sounds really strange. It produces some sort of a pulswave sound...

And i had no luck using "Asio4All" as my primary audio driver - I normally use this with Reaper with no problems.

Stringer, you are the best

Stringer, you are the best tester in the world! I'm taking note of all this issues and suggestions, really thanks!

I'm planning the Real time rooms too, but it's not a priority in my long todo list :)

Elieser

*** May Have Found a BUG...

*** May Have Found a BUG... Had Jamtaba up for about an hour unused and noticed that the 'Rooms to Play' list didn't update. Several shutdowns and restarts of the program failed to clear the old list which didn't reset to the current users until the program crashed.

The program then stuck on the 'new' old set of users even after stopping the program using the task manager or going to a room in use to prompt a reset (Ninbot 2050 showed the old list on 'rooms to play' tab and the correct list on the active room tab.)

On rebooting the computer Jamtaba crashed again, but then came up with the correct current list. Here are the details given on the crashes which was apparently caused by the GTune VST:

Problem signature:
Problem Event Name: BEX64
Application Name: Jamtaba2.exe
Application Version: 2.0.0.0
Application Timestamp: 56084dff
Fault Module Name: GTune.dll
Fault Module Version: 1.2.4.4
Fault Module Timestamp: 5553b2ba
Exception Offset: 000000000000b7f3
Exception Code: c0000409
Exception Data: 0000000000000005
OS Version: 6.3.9600.2.0.0.256.48
Locale ID: 1033
Additional Information 1: 7738
Additional Information 2: 77388f7042db80cb1d0ca5b93d38baae
Additional Information 3: e307
Additional Information 4: e307183e8a12f0e071a3f8c301ecf324

After removing the GTune VST Jamtaba 2 (64) no longer crashes, but it still seems to take a full reboot of the computer to refresh the 'rooms to play' list.

Spin around three more times lol... cheers!

Hi Elieser, I just got a new

Hi Elieser,

I just got a new machine a couple of months ago (x99 motherboard, 5820K cpu, ddr4 ram, 64-bit Win 8.1 pro on SSD, Focusrite Scarlett USB 2 ASIO interface) and Jamtaba 2 installs / runs seamlessly including all 64-bit VSTs in several different folders.

However, my input on the VU meters seems low and peaks at around 33% using the same external settings (i.e. amp, ASIO box, etc) that I use for Reaper. I went into a session and was told that everything sounded fine, but Db markings on all the meters except the metro might be more reassuring for adjusting levels in a jam.

Red and green states on the 'Transmit' button also might be more foolproof than just shading out the user panel (which I like) and you could use an avatar on the task bar which currently shows as a blank page.

I also noticed that the room you're in (i.e. ninbot 2049, etc.) isn't displayed and this seems like it might be a good addition too.

My only other question is will the realtime options be returning?

Awesome job and thanks!!!

BTW - Avira free didn't red flag anything on the install and there were no issues typing all the punctuation available into chat.

Echnaton I had similar issue

Echnaton I had similar issue at first and it had to do with avast holding the app in some kind of safe mode. Once I tuned that off in avast I had everything working

Echnaton I had similar issue

Echnaton I had similar issue at first and it had to do with avast holding the app in some kind of save mode. Once I tuned that off in avast I had everything working

Karma and Brett, thanks for

Karma and Brett, thanks for your help!
------------------------------------------------
Hi echnaton9000! Are you using the last installer version? I release the last version yesterday (09/27/2015).
If you have problems please try run as administrator or try bypass your anti-virus.
Another possibility: Jamtaba generates a log file called "log.txt" in C:/Users/[your user name]/AppData/Jamtaba 2. If you send me this log file I can see the error details and work to fix it.

Jamtaba is working in windows 7 for me and other ninjamers, so I'm suspecting your anti-virus.
-------------------------------------
Jon, I will check this issues. Jamtaba is resampling internally and I test many times using different sample rates (44.1 KHz to 192 KHz). I will double check this.

See you!

well I found something odd

well I found something odd when using sample rate 48000 Hz. When the listen button is pressed the sound plays faster and hi pitched. Sometimes it crackles.

Another thing is that once inside a room using sample rate 48000 hz the jam sounds out of sync with regards to the metronome.

Wow! C++ VST... :-) Nice job

Wow! C++ VST... :-)

Nice job elieser! I liked version 1 with the very good sync feature!

Unfortunately Jamtaba 2 refuses to work here too... :-/
I can install it on Windows 7, it starts, shows its interface for a short while and then it dissapears...
I can see the process in the taskmanager but cant stop it.

But thanks for so much afford! Im sure when it works it will be of very much profit to us ninjamists! :-)

Have fun/k!

hi elieser, installed on

hi elieser,

installed on windows 64, no problem other than Avast antivirus was concerned with it at first. I have a question, how do we load our vst plugins? i set the paths but nothing shows up. Do I have to run the scan? If i do that I get alot of runtime errors. Other than that seems fairly stable. Great looking interface! and nice work.

brett

EDIT ok now its working. I guess I had to restart the app and then run the scan to the folders i selected and the plugins were found

I tested this morning and

I tested this morning and everything is good. It work perfectly with my computer (windows 7 64 bit). I wait the Jam taba VST !!!!
Thank you for this release. Very good job.

Urrrrruuuullllllll, nice

Urrrrruuuullllllll, nice news Jon! Thanks for testing Jamtaba!

Elieser

now all my plugins pass ok!

now all my plugins pass ok! Great job Elieser!

Karma and Jon, thanks for

Karma and Jon, thanks for your help!

I test dspTrigger and see the error. It's fixed now! I test the audiorealism BL2 too, working in my machine now.

Can you reinstall Jamtaba 2 and test again, please?

Tom, thanks for testing in your machines and thanks for allow all this messages about Jamtaba in ninbot forums.

Elieser

Really great job

Really great job Elieser.
Tested on Windows 7 + Maudio
and OSX 10.9 works great.
(btw how did you keep it from feeding back the mic? haha)

I PM'ed you, I'll paste here

I PM'ed you, I'll paste here as well for info. I use Mac OS X 10.6.8 Snow Leopard

Process: Jamtaba2 [735]
Path: /Applications/Jamtaba2.app/Contents/MacOS/Jamtaba2
Identifier: com.yourcompany.Jamtaba2
Version: ??? (???)
Code Type: X86-64 (Native)
Parent Process: launchd [135]

Date/Time: 2015-09-27 15:37:55.132 +0300
OS Version: Mac OS X 10.6.8 (10K549)
Report Version: 6

Interval Since Last Report: 33818346 sec
Crashes Since Last Report: 327
Per-App Crashes Since Last Report: 3
Anonymous UUID: 3BD15A0C-1458-49F7-9FA1-FED6EBA10877

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread: 0

Dyld Error Message:
Library not loaded: /usr/lib/libc++.1.dylib
Referenced from: /Applications/Jamtaba2.app/Contents/MacOS/Jamtaba2
Reason: image not found

Binary Images:
0x7fff5fc00000 - 0x7fff5fc3bdef dyld 132.1 (???) /usr/lib/dyld

Same problem for me too !

Same problem for me too ! Windows 7 64 bits crash when scan or not scan vst. Even by disabling antivirus and started as administrator.
Thank you for your labor Elieser.

64bit version on win7

64bit version on win7 working, but crashes when reading some plugins. specifically audiorealism ones, dsp trigger and izotope spectron Once removed those it scans the rest ok, but once finished crashes in my system. Once vst path removed, works ok.. Strangely for me it crashes when exiting the application, but I have to say it looks really amazing job. thx, man.

Hi Guys, I found the problem

Hi Guys, I found the problem and is fixed now (a little mess with 32 and 64 bits DLLs). I test in Windows 8 (x64), and Windows 7 (x86 and x64).

Please, can you test again?

Elieser

You know Elly when you

You know Elly when you master VST in c++ ya heading to a world where money is made. ;)

Doesn't work Elieser, be

Doesn't work Elieser, be very doubtful all our different vc's blocked with out telling us.

Run as admin, no go.

Somit missing when u packed it up, u shoudl have added a debug flag int he commandline then ill run it with it and tell ya what it says.

Jon and Gaz, another user

Jon and Gaz, another user report me a problem with antivirus.

Please, can you test again:
1 - Running as administrator?
2 - deactivating antivirus?

AndyMc, JamTaba 2 is standalone only at moment. The VST plugin is in my TODO list.

Elieser

:S no workey. Tbh though

:S no workey.

Tbh though unless it's a simple app that can be used as VST with normal ninjam cpu usage I'd never use it.
I can handle a little more but Jamtaba 1 was 4 times the cpu use than running reaper and cubase with vsts.

Stephen, the younger one you know made a great google chrome app of ninjam, works flawless, doesn't xmit audio yet but it works like an app should. Lagless and flawless, if you have an app that sucks cpu which shouldn't then it's s*** and needs sorting.

But it's cool to see you wrote it in c++, much better choice.

Hiya Elieser, is this a vst

Hiya Elieser, is this a vst version too, if so could their be option to choose vst dir.

I've tried both versions

I've tried both versions 32/64 ..

As Jon says, installs fine.

Doesn't open and not showing any errors (Windows 10).

Great is released! Install

Great is released!

Install was ok, but will not run:

1.- tried on win7 x64: jamtaba 64bits install ok. When try to run, error appears: "the app could not be initialized (0x000007b). Click ok to close it"

2.- Tried on win XP: jamtaba 32bits.install ok. When try to run error appears: "Unable to open jamtaba2.exe. CreaeProcess Failed; code 193. %1 is not a valid win32 application"

:(



    © 2013 ninbot.com All rights reserved