Jamtaba 2 released!


Hello everybody! After some months with a lot of programming JamTaba 2 is finally released!

Some Jamtaba 2 details:

  1. Jamtaba 2 was totally rewrited in C++ (the old version was writed in Java) and run as a native application (32 or 64 bits). The result is a fast application using less memory and CPU.
  2. Low memory usage. The old version used 300 MB of memory and the new version uses less than 30MB, a huge difference.
  3. Low CPU usage in comparison with the old version.
  4. VST plugins. Jamtaba 2 can act as a VST Host and open VST plugins (32 and 64 bits).
  5. Now you can create 2 stereo channels, and more 2 subchannels.
  6. Chat message translation. In another ninbot forum post the ninjamer Gaz suggested a "translation feature" for chat. It's done, a cool idea!
  7. Better user interface, more clean and beautifull.

Have fun using Jamtaba 2 and please report any problem!

www.jamtaba.com

Elieser

Is there loop saving in

Is there loop saving in Jamtaba? Thats cool!

Reaper crashes when i save

Reaper crashes when i save loops to ogg. wav is working ok. Can you make looper working offline? or separate looper plugin.

Thank you. It is good

Thank you. It is good plugin. I like looper in jamtaba, it would be great using looper offline.

Nice Khz, let's see if

Nice Khz, let's see if somebody in the linux forum can help. My linux skills are just the minimum.

linuxmusicians.com Jamtaba

Antonio - OiO ok Elieser !

Antonio - OiO ok Elieser ! Very good job; Obrigado meu.

I don't use sudo and have

I don't use sudo and have not installed it, nor do I want to install it.
I install it "classic" as root (su).
Is it because of the fact that it will end up in my /root directory?

Om@freedom ~ $

Cool THX! I'm going to try

Cool THX!
I'm going to try to.
I'm more like a must have noob (in german DAU
(Luser). ;-)

But if there's anything I can do, I'd love to help.
https://linuxmusicians.com :: Re: inet-concert
Cheers@freedom ~ $

Hi Khz, this is the install

Hi Khz, this is the install script for linux

As you can see in the 3rd line the destionatio directory is always ${SUDO_USER}.

If you are good with scripts please propose a change in github.

First, THX! If I install

First, THX!

If I install Jamtaba under GNU/Linux it is in the "/root" directory - why not in the "/opt" directory - and I can't start it as a user.
Can someone give me a tip on how to start it or better: Can I have it installed after "/opt"?
I tried to save:
# chmod +x ./Jamtaba2_Installer_64bits.run
##
# ./Jamtaba2_Installer_64bits.run --target /opt
Creating directory /opt
Verifying archive integrity... 100% All good.
Uncompressing Jamtaba 2 Installer 100%
Installing Jamtaba 2 in /root/Jamtaba2

##
~ $ /opt/Jamtaba2
/opt/Jamtaba2: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory

##
# emerge -1av libpng

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] media-libs/libpng-1.6.32:0/16::gentoo USE="apng (-neon) -static-libs" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="sse" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB

Would you like to merge these packages? [Yes/No] no

Quitting.
##
${helpheader}Makeself version 2.2.0
1) Getting help or info about $0 :
$0 --help Print this message
$0 --info Print embedded info : title, default target directory, embedded script ...
$0 --lsm Print embedded lsm entry (or no LSM)
$0 --list Print the list of files in the archive
$0 --check Checks integrity of the archive

2) Running $0 :
$0 [options] [--] [additional arguments to embedded script]
with following options (in that order)
--confirm Ask before running embedded script
--quiet Do not print anything except error messages
--noexec Do not run embedded script
--keep Do not erase target directory after running
the embedded script
--noprogress Do not show the progress during the decompression
--nox11 Do not spawn an xterm
--nochown Do not give the extracted files to the current user
--target dir Extract directly to a target directory
directory path can be either absolute or relative
--tar arg1 [arg2 ...] Access the contents of the archive through the tar command
-- Following arguments will be passed to the embedded script
EOH

This works at least without errors in the /root directory
Jamtaba2 # ./uninstaller.sh

Hi Oio, we briefly discussed

Hi Oio, we briefly discussed the ideia here.
But the job is complex and very time consuming.

Antonio -Oio.

Antonio -Oio. Ola Elieser. Have you ever thought of developing Jamtaba for Android tablet?

Hi Elieser, Great works like

Hi Elieser,

Great works like a charm ..
Rhanks for taking time answering.
Great job..

Cheers
Eric

Music is my best friend and it will be my last..

Hi HammerOn, I tested here

Hi HammerOn, I tested here with Ableton Live 9 Trial and works like a charm. The steps are:

1 - Insert Jamtaba as a VST plugin in a audio track (nothing special here).

2 - In this "Jamtaba track" select your first inputs in "Audio From". These channels inputs will be your first Jamtaba stereo channel. Again, nothing special here.

3 - Create another audio track.

4 - The special part: In this new track created in step 3 select your "Jamtaba track" in "Audio To". Now you will see a second selector in "Audio to" area with a default value "Track in". Just change this "Track in" value to "3/4 - JamtabaVST". Now you are sending this channel to the second stereo channel in Jamtaba.

Have fun with these routings!

Elieser

Jamtaba latest version 64

Jamtaba latest version 64 bits VST with Ableton Live.

Hi Elieser,

Eric here aka HammerOn in Ninjam/Ninbot.
I am trying to use Jamtaba latest version 64 bits VST with Ableton Live.
Works like a charm so far except that I cant route output to a second channel.

In REAPER with reaninjam vst its possible to route for instance channel 1/2 to Ninjam channel 1 and channel 3/4 to Ninjam channel 2.

How can I setup this in Jamtaba 64 bits VST.

Thanks in advance
Good job btw

Cheers
Eric

Music is my best friend and it will be my last..

Just FYI Jamtaba is now

Just FYI Jamtaba is now available for Linux too! (tested in Ubuntu 14). Check it out!

Both, processed(wet) and

Both, processed(wet) and unprocessed(dry) sound come out after vst chain.
Has anyone been experiencing this?
i play electric guitar and I just realized about this. Tested on both 32 bit and 64 bit versions of jamtaba 2.0.2
I just tried adding free distortion/ guitar amp simulator plugins to play with my electric guitar in jamtaba and realized that I'm hearing both: the original unprocessed sound and the processed sound after the vst chain.
I mean i could have extreme metal distortion on and hear that processed sound but at the same time hear the unprocessed sound coming from the same track. I've tried setting the input to mono and also to stereo and the same happens.
Easiest way to confirm this was by lowering the internal vst output to 0, that way I couldn't hear the processed sound but was still hearing the original unprocessed sound.
Confirmed this with many plugins which have different variations of vst inputs and outputs:
Juicy77 (1input and 1 output), Overloud's TH1 (2ins 2outs), redskull distortion (1in 2 outs), classic chorus(2ins 2outs), Mokafix Creamtube(2ins and 2outs) and many others, always setting the internal vst output volume to 0 and still hearing the original unprocessed sound.
Can you confirm if this happens to you?
Cheers

Hi, Elieser. Just downloaded

Hi, Elieser. Just downloaded v. 2.02 x64

Looks there's a minor bug when you access the vstplugins preferences menu directly (old bug). The directories appear blank until you change the tab (to recording for example) and come back. Then they appear.

I installed the arturia V colection 4 and I found Jamtaba crashes with the Analog Lab.dll plugin.

I can't tell what's the problem with kontakt 4 yet, but the vst on reaper and standalone kontakt work ok. My interface is Roland Octapad and i'm connected using usb midi using the VENDOR driver(It's roland's specific driver), not the generic driver that comes with windows. I'll continue testing....

Thx

Wow what a commitment you've

Wow what a commitment you've made, the major shift to C is what it needed. Nice work!

I’m on latest (just

I’m on latest (just released sept. 30th) OS X El Capitan 10.11 (so far I LOVE the new OS X and won’t be going back, things are really stable for me) have yet to get jamtaba 2 working though. Guess we’ll just have to be patient or use parallels/bootcamp. Looking forward to it though :)

Yes Elieser I'm still using

Yes Elieser I'm still using 10.6.8 for some PPC apps (mainly editors for synths etc) I would be very happy if it works on 10.6 but if it works on Torben's mac, I'll make a seperate 10.7 drive to test it.

Hi Jon, thanks for your

Hi Jon, thanks for your positive feedback. In Jamtaba I'm not filtering your midi messages. I'm just grabbing the midi messages from your midi device and dispatching for your VSTi, no filtering. Please check if the problem with low velocity is related with your midi controller. Many midi controllers behave poorly in low velocity notes, I have one of these midi controlles :) If possible test the same VSTi with the same midi controller in Reaper. Let me know the results...

About the audio quality: The only explanation I have in my mind at moment is: Jamtaba audio engine is 32 bits, and the ninjam original code (I'm supposing Reaninjam use the same code) is 16 bits. But I'm not shure if this is the real explanation. I can't think in other explanations at moment. In Jamtaba I'm not compressing/limiting anything, just applying gain, pan and mixing/summing the audio streams (all operations computed in 32 bits). Using more bits we have more head room, and the dynamic is better. But this is a very subjective topic.

Another thing in my mind: Many ninjamers are playing with low input gain. This is not good in digital audio. If you have 16 bits (assuming Reaninjam) but is playing with low input gain you are using less then 16 bits to convert your analog audio to a digital version, and 16 bits are the minimum for a "good quality". So, with low input gain every sample in your audio is truncated in the vertical axis (amplitude/dynamic) because you have less possible values (less then 16 bits) to 'draw' the digital audio wave. If we have 6-8 streams/musicians using low gain the resulting audio can be low quality after some calculations (gain, pan, and summing). Again, this is theory, in practice this is very subjective and I'm not the God master super duper in this topic, my knowledge is just enough. So, don't trust me too much :)

See you!

Hi, Elieser Very stable

Hi, Elieser

Very stable release in my computer. Kontakt implementation has improved, I mean from no notes recognized now it recognizes some of them, but still not the low velocity ones.

And now the rooms update correctly. I can still hear some crackle when using the 'listen' button, but only on the 2nd room listed. This don't happen with the first one.

One observation: I found jamtaba does not distort the main output even when ninjamer levels are awfully loud. Is this something you did on purpose? I say this because the reaninjam plugin sounds very bad when this happens compared to jamtaba. Anyway a master volume to match the overall mix is never a bad idea.

Thx ,man for your work.

Hi Bilos! The bpi and bpm

Hi Bilos! The bpi and bpm fields in Jamtaba user interface are editable. You can type the desired bpi/bpm value and press 'return' to change the bpi or bpm to any supported value. If you don't like this approach (some users are 'command line guys') you always can use the chat and type the vote bpi/bpm commands. I have played some mind puzzle jams in 5/4 and 7/4 using Jamtaba and I'm not a 'command line guy' :)

About BPI > 64: Reaninjam is supporting BPI > 64? I think 64 bpi is a server limitation, and last time I tested 64 bpi was the maximum value. But I'm not shure about this. It's easy change the code to allow bpi > 64.

KeyDudes and Torben, the mac version need more love, at moment I'm focusing in windows. KeyDudes, I do some research and at moment it's very trick release a Jamtaba for Mac OSX prior 10.7 (are you using 10.6, right?).

Bebop1024, I have some strange behavior in www.jamtaba.com too. When I enter in the site my browser (chrome) shows an error, and 3 seconds after the error the page appears. I will investigate this annoying problem soon.

See you!

Hi Elieser and all, The url

Hi Elieser and all,

The url www.jamtaba.com is ko on 2015/10/06 at 18:30PM of france ;).
And Thank you for your involvement
See you

Elieser you did a good

Elieser you did a good computer work.
But you satisfy the software needs of some, and makeup screens

As a purist musician, I do not use Jamtaba because I can not choose, and ask users to vote jamtaba Specifics BPM / BPI.
To some of my jam, I recorded BT BPM 88, 127, 180, 320, and the voting system is not suitable. Ditto for the BPI.

As a musician I use times signatures; 3X4, 5X4, 7x4, 12X8, ... needs very long BPI Sometimes > 64 for neoclassical.

New drawback with Ninbot :
I remain with ReaNINJAM due to the limitation of Jamtaba!
Jamtaba users who can change the setting of a current jam by voting fixed values :(
or Jamtaba users who can not vote my requests :(
it's not cool! :(
Maybe for Christmas you could put in your lists :)

Video explanation time signature FR

Let's review popular theory based on the rythme..........Donkey Bilos

Eagerly waiting for the mac

Eagerly waiting for the mac update :)

first release crashed before

first release crashed before even opening, new one crashes after initial opening when it says error connecting in jamtaba server..running OS X 10.11 non-beta

Hey elieser, Guitar Rig now

Hey elieser,

Guitar Rig now works like a charm! Also the new green transmit button is much better than the old grey one! Thanks a lot for the fix! :-)

Awsome work you have done there!

Have fun/k!

PS: using JT2 right now and its really nice ... I like the interface! :-)

Woohoo, with this new 2.0.1

Woohoo, with this new 2.0.1 jamtaba release mobius is working jus fine without crashing! geting ready for some ninjam looping madness with jamtaba! Also the color in the xmit button looks better Thanks Elieser!

Hi Guys, I released a new

Hi Guys, I released a new version today. I fix many problems reported by ninjamers here. Thanks for all this help, I really appreciate! This is the change log:

10/03/2015 - V 2.0.1 released.

  1. Fixed the bug in 'room preview' pitch. Now the 'room preview' is resampled correctly.
  2. Fixed the problem in ninjam streams out of sync when users are using high sample rate (192 KHz) and small buffer sizes (128 samples).
  3. Fixed the bug in Guitar Rig 5 (a digital noise) and possibily in other multi input VST plugins (Guitar Rig 5 uses 4 inputs).
  4. Fixed bugs with some VST plugins reported byte ninjamers (dspTrigger, ABL2, GTune).
  5. Change the color of xmit button on/off to green/red.
  6. Added a menu to report bugs and suggest improvements.
  7. Some improvements in user interface.
  8. Showing db values for tracks and VU peaks.
  9. Fix a bug in VST plugins when sample rate is changed.
  10. Dialog to confirm bpi/bpm vote removed. Now a button appears in chat to confirm the vote.

Hi Gevi. In my system using

Hi Gevi. In my system using Jamtaba 32bits mobius2.5 works fine. the file is called mobiusvst2.dll and it's different from mobiusvst.dll

agg, what a shame the mobius

agg, what a shame the mobius looping vst crashes :(
I managed to load the vst and use it for a while within jamtaba but at some point I closed jamtaba and tried to start it again and crashed because of mobius. Removing the mobiusvst.dll entry in the from the jamtaba.json file allowed me start jamtaba without crashing but no more mobius sniff lol.
It would be so cool to use it in jamtaba with ezdrummer and oher plugs since jamtaba is syncing so well with the ninjam metro.
I tried adding mobius to jamtaba with vst wrappers like jbridge and the Legree plugin that allows to connect to vsthost as a plugin but they all crash apparantly when mobius starts to process.

Cheers

wait what??? lol!

wait what???

lol!

Jon, I agree about the

Jon, I agree about the "change bpi" dialog box, I will use a less invasive solution. In old Jamtaba a button "Vote bpm/bpi" appears in chat when somebody propose new bpm/bpi. I think this solution is good and no invasive.

I will put mobius in the "bad plugins list" :)

At moment I'm not receiving donations. I will wait for the end of world economic crisis :)

thx, man for taking the

thx, man for taking the time. Your work is really appreciated. I'm switching to Jamtaba slowly as it gets more stable, but for me it's very refreshing to escape the reaninjam tyranny for so many years.

One thing that I found really cool is the "other wants to change the bpi ...do you accept?" dialog box, but IMHO it's a little invasive that it appears so big in the middle. Maybe it could be a side located button that turns purple or something :D hopefully controled by midi. (yeah...i know I'm asking too much..lol)

ohh and I tested mobius 2 (it's only x86) with jamtaba 32 bits and it makes jamtaba crash some times. Overall it works pretty good and it's synced with the ninjam metro!

PS. Where's the donate button/bitcoin adress?

Hi flip, nice news!!! I

Hi flip, nice news!!! I will work in a solution to allow Jamtaba 64 bits load 32 bits plugins too, but this is in bottom of my list :)

Elisier i reinstall jamtaba

Elisier i reinstall jamtaba with 32 bits and i'm surprise it WORK!!
later i config fcb 1010...
thankS MAGIC MAN...

flip, Reaper 64 bits (and

flip, Reaper 64 bits (and many other prefessional DAWs) can load a 32 bits VST plugin. Maybe you are loading Amplitube 32 bits in Reaper 64. Unfortunally this is not possible in Jamtaba at moment. Try uninstall your JamTaba 64 and install JamTaba 32 bits. If your Amplitube is a 32 bits plugin Jamtaba 32 bits can load this plugin (I hope).

elisier: i have windwos 64

elisier:
i have windwos 64 bits and i SHURE install 64 bits version.
in the same computer i have the reaper that works with ninjam and work perfet with amplitube sinsce 3 mounts.
(so amplitube 3 it's really 64 bits)
thank you for your lost time...

Jon, I will put Kontakt 4 in

Jon, I will put Kontakt 4 in my "bad plugins list" :) I will check for a fix.

flip, Jamtaba 32 bits can load only 32 bits plugins, and Jamtaba 64 bits can load only 64 bits plugins. Please check your amplitube, it's 32 or 64 bits? And your Jamtaba, is 32 or 64 bits?

i install and the only one

i install and the only one problem is loading vst, there is no vst in my pc!
seems to be a problem with amplitube 3 VST
I'M USING windows 7 64 bits!
how to fix this?
good job to try remaque jamtaba

Hi Elieser, I'm using

Hi Elieser, I'm using kontakt 4 64 bits my laptop is win7 x64

Jon, I'm using Kontakt 5

Jon, I'm using Kontakt 5 here in windows 8.1. What version of Konkat are you using?

Hi Elieser I'm unable tu run

Hi Elieser I'm unable tu run KONTAKT properly. In general other plugins receive midi from an external interface ok, but not KONTAKT. I checked using omni mode too and enable all channels, but the only data it recognizes is CC; no notes are going in.

Hi Gevi, thanks for your

Hi Gevi, thanks for your feedback! I need a better color scheme for xmit button. Stringer suggest a good idea (green and red for xmiting and not xmiting).

If possible tell me the name of problematic plugin and I will put in my list of "plugins to check".

See you!

Hi man, awesome work!! I

Hi man, awesome work!! I just downloaded this 2.0 release and tried the 64 bit version.
Really great!
Very nice to be able to load vstis, vsts from inside jamtaba not having to rely on external apps.
What I really really loved was seeing that ezdrummer syncs to jamtaba's / ninjam servers metro automaticallly !! Loved this!
No more finding the exact sync point, so great!.
So far I only got a certain creash but apparently due to a faulty vsti.
Congrats! Parabens!
Alex

Question: is the "Transmit" button missing a checkbox? I don't know exactly when it's transmitting and when it's not
Brigado

Hi flip, Jamtaba get midi

Hi flip, Jamtaba get midi messages from your connected midi controllers and send to your VST plugins. I think you can use this controller without problems. I don't test amplitube yet, but I test the free LePou plugins and works fine!

Elieser

Hello everybody can i play

Hello everybody
can i play fcb1010 midi controler+ amplitube vst with jamtaba2?

Stringer, try remove the

Stringer, try remove the file Jamtaba64.json in C:/Users/[your user name]/AppData/Local/Jamtaba 2.

This is the Jamtaba 'config' file. Maybe Jamtaba is using a 'old and wrong' information about your devices. Just delete this file, Jamtaba will recreate the file when you reopen.

Please copy your file before delete, so we can see the problematic entries.



    © 2013 ninbot.com All rights reserved