Anyone successful midi loops?


Hi all
I'm trying to have Reaper play a programmed loop using the sync function in Jamtaba but it drifts out of sync. Anyone have midi loops sync successfully in Ninjam somehow? I'd like to learn how. Thx

https://github.com/elieserdejesus/JamTaba/issues/365

I use them for drums and

I use them for drums and synths (using Reaper 5 & reaninjam plugin) , it stays in sync unless net connection drops out badly due to other circumstances.

If you are routing to hardware synths with a USB > DIN MIDI router (like Roland, MOTU, M-Audio etc.) make sure you send MIDI clock to according unit in Reaper preferences.

I used up to 64 bpi (bars) with audio & midi without problems, provided your net upload speed is consistent. (works nice with 512 kbit upload rate)

Heck, I even did live soundtrack (movie score kinda stuff) jams sometimes, but usually it leaves me in single player mode (courtesy of AndyMC) :) fills the audio spectrum very fast unfortunately :P

hello strange things you

hello

strange things you describe Krillo
I am very often using syncing with jamtaba in reaper without problems

Maybe changing the vst who plays the midi could help .. i am using Stylus Rmx and copying midi files on the track in reaper without any problems for years ... maybe the vst is using too much your computer ram , you are running a laptop ? you have lot of Ram memory ?

Are you using the last version of jamtaba ?

hope it helps you.

That's _weird_ in a weird

That's _weird_ in a weird way! Thanks for being patient enough to try it out.

Jamtaba cannot know that the audio it's being fed by Reaper is coming from MIDI through a synth, so that does seem to rule out it being a Jamtaba bug.

What I can't understand is why Reaper would behave like that.

What if you have one audio track and one MIDI track (the same length) looping? Does the MIDI drift even locally rendered? (Is there a way in Reaper to say "record 20 repeats"?)

Sounds like a bug, yes. You

Sounds like a bug, yes. You can use the built-in looper Jamtaba has once you get your loop going in the meantime.

Ok thanks, I've done some

Ok thanks, I've done some furter tests:

Sync or not sync made no difference in the drift issue. Exact same amount of drift occurred regardless of using Jamtabas sync-function or not. Of course the challenge of hitting play at the right time made it not line up as with using the sync-button, but the amount of drift remains the same. The drift is 32 samples per interval at 44,1kHz samplerate. I tested only at 120BPM and BPI 16.

When using a wav-file loop, it remains in sample accurate sync, so the issue is definitely related to MIDI.

For clarification: The amount of offset is constant within one interval. It is when the next interval starts that the MIDI-loop gets delayed by another 32 samples. By the next interval another 32 samples and so forth.

Maybe one would get different results with MIDI-loops using a host other than Reaper.

I wanted the functionality to have some percussionloops at hand when jamming, as it tends to glue timing together. I sometimes find that mixdowns sound out-of-time. More so than I would be willing to attribute to my own timing ;)

It's been a while for me,

It's been a while for me, but as I remember Jamtaba's metronome is always in perfect sync with reaper's metronome. I use asio4all with 2.3 ms latency. I use the magnet in reaper to set the left and right markers so the loop exactly matches bpi and record midi live through USB. Midi data feeds kontakt. I do not have dropouts because my laptop is optimised for audio, but I'm sure this could be problematic for the sync.

That's my

That's my impatience...

OK... The local intervals aren't saved from what the server hears - they're saved from what the client sends. The picture still doesn't answer all the questions in terms of what's going on.

Do you only get drift when synced? (i.e. is it definitely sync)
-- set Reaper and NINJAM to 120 BPM, stick four audio beeps in per bar, see if that drifts if you just let Reaper loop over four bars of it against a 16BPI interval - even WITHOUT syncing, it should manage to stay in time

Do you only get drift when synced and using a MIDI source? (just to see if that makes a difference)
-- set Reaper and NINJAM to 120 BPM, stick four audio beeps in per bar, see if that drifts if you just let Reaper loop over four bars of it against a 16BPI interval - but with sync enabled (i.e. not using MIDI but using sync)

Do you get told others are hearing drift? (i.e. is it only local)
-- this is the tricky one; an alternative is to have a Reaper channel with ReaNINJAM on, with no Master send, with ReaNINJAM recording enabled and log that into the jam, run the looping and compare ReaNINJAM's saved intervals

Do your local performed (rather than synced) intervals also show drift when sync is on? (i.e. is it only control of the host)
-- same as above for testing

(I'm also frustrated I can't test this myself -- my music gear is split from my work area currently.)

Please read my post

Please read my post carefully before being condescending.

That's not MIDI. Try to be

That's not MIDI. Try to be clearer in what you're trying to do.

It's _possible_ there may be a bug in Jamtaba - but it's not clear from what you're saying what's happening.

Do that, with multitrack

Do that, with multitrack saving enabled. Then log in to a server, sync your MIDI sequence as per your instructions. Let it play for 20 intervals. Log off and open the saved project, then move the last interval onto a new track so that it snaps parallell to the first interval. You will see there is drift.

http://www.mediafire.com/view/mh58c15f5ymmiu1/drift.jpg/file

Your title says "Anyone

Your title says "Anyone successful midi loops?" Do you mean MIDI or audio? MIDI is not audio. Frequency has no meaning here. You need a MIDI instrument to turn MIDI into audio:

  • Set up a track in Reaper directed to where you're Jamulus instance lives.
  • Insert an instrument to play the MIDI events (synth, sampler, your choice)
  • Set the Reaper BPM to the BPM of your MIDI file
  • Paste in the MIDI file at the start of the track. If you miss, move the item to the start of the track.
  • Now you can adjust the BPM... Set the Reaper BPM to 120
  • Set the NINJAM BPM to 120
  • Set the NINJAM BPI to the length of the MIDI phrase IN BEATS. (So, if it's eight bars of four quarter notes, you want a BPI of 8 times 4 = 32.)
  • Click Sync in Jamulus.

I think that's it. You might need to click Play in Reaper, too, but I can't remember.

-----

If you actually meant audio, then the BPM of the audio file can be wrong. It might say "BPM is 120" when it's actually 120.1838761 or something. In that case, drift is inevitable. Bin the file and make your own music.

Interesting! Could you

Interesting! Could you please list your settings like sample rate and buffer size?

I usually use the smallest buffer 48 samples at 44,1kHz and have no issues with dropouts. Larger buffer does make drift worse but smaller buffer does not eliminate it either.

I have done exactly that,

I have done exactly that, krillo. Works perfectly in sync in my system.



    © 2013 ninbot.com All rights reserved